Educational Videos Temporarily Unavailable

Incident Report for Butterfly Network

Resolved

Access to educational videos in the Compass app and cloud platform has been restored. Thanks for your patience while we worked through this.

If you have questions or need assistance, please contact us at support@butterflynetwork.com or call 1-855-296-6188.
Posted Aug 19, 2026 - 10:02 EDT

Investigating

We’re aware that educational videos in the Compass app and cloud platform are currently inaccessible. Our team is actively working to restore access. We’ll update this page as soon as the issue is resolved and apologize for the inconvenience in the meantime.

If you have questions or need assistance, please contact us at support@butterflynetwork.com or call 1-855-296-6188.
Posted Aug 19, 2026 - 07:27 EDT
This incident affected: Butterfly Cloud.