Study Search Interruption

Incident Report for Butterfly Network

Resolved

Thank you for your patience. We have identified the source of the issue and the resolution is in place. Studies should becoming increasingly available via the study search.

Please don't hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted Apr 09, 2026 - 18:12 EDT

Identified

We have identified the source of the issue, and a resolution is in progress. We will continue to provide updates as work proceeds.

Please don't hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted Apr 09, 2026 - 12:38 EDT

Investigating

We are currently experiencing a service interruption. You can still log in, scan, and use Butterfly Cloud, but study search is offline. List view remains available as an alternative way to access your studies.

We are investigating and will provide updates as soon as possible. We understand the inconvenience this may cause and appreciate your patience.

Please don't hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted Apr 09, 2026 - 10:57 EDT
This incident affected: Butterfly Cloud.