Worksheet Issue

Incident Report for Butterfly Network

Identified

We have identified the source of the issue, and the resolution is underway. We will continue to track the status of this issue and will update you as the resolution proceeds.

We understand the significant impact this may cause. Please don't hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted May 05, 2026 - 18:08 EDT

Investigating

We are investigating reports of issues with Butterfly Cloud that may prevent users from viewing worksheets. Our team is actively reviewing the situation and working to ensure a return to normal performance as soon as possible.

We understand the inconvenience this may cause and appreciate your patience. We will share updates as we learn more.

If you have questions or need assistance, please contact us at support@butterflynetwork.com or call 1-855-296-6188.
Posted May 05, 2026 - 16:20 EDT
This incident affects: Butterfly Cloud.