Scheduled Maintenance: Phone Support

Incident Report for Butterfly Network

Resolved

The support system upgrade has been successfully completed. All support channels, including the support portal within the mobile application and cloud web browser, phone support, and email support, have been fully restored.

Thank you for your patience as we completed this transition.

If you experience any issues, please contact us at support@butterflynetwork.com or call 1-855-296-6188.
Posted Feb 18, 2026 - 15:42 EST

Monitoring

On Wednesday, February 18, we will be upgrading our phone support system.

During this time, calls to our Support line (1-855-296-6188) may experience a brief delay in connection. We expect any interruption to last less than 15 minutes between 9:00 AM and 10:00 AM EST.

Email support will remain fully operational during this window. If you need assistance while the phone line is temporarily unavailable, please contact us at support@butterflynetwork.com, and our team will respond promptly.

We appreciate your patience as we complete this upgrade and continue improving our support experience.
Posted Feb 17, 2026 - 15:51 EST
This incident affected: Butterfly Cloud.