Butterfly EU Log-in Incident
Incident Report for Butterfly Network
Resolved
Service has been restored as of Tuesday, April 9 at 2:23 PM UTC.

Please don't hesitate to contact Butterfly Support at https://support.butterflynetwork.com with any questions or concerns.
Posted Apr 09, 2024 - 10:44 EDT
Investigating
We are currently experiencing a system outage for customers in the UK and EU regions. Those customers may experience issues logging into their Butterfly. Users that are currently logged in should be able to continue using the system.

We are investigating the issue, and will provide an update as more information becomes available.

We understand the impact this may cause, and we will post an update as soon as it is resolved. Please don't hesitate to contact Butterfly Support at https://support.butterflynetwork.com with any questions or concerns.
Posted Apr 09, 2024 - 09:45 EDT
This incident affected: Butterfly Cloud and Butterfly Store.