Service Interruption
Incident Report for Butterfly Network
Resolved
We have identified the root cause of the issue as an issue with a vendor service and have taken steps to remediate it. The Butterfly Cloud application should be functioning as normal now.
Posted Sep 01, 2023 - 09:52 EDT
Update
We are continuing to investigate this issue and will update once it is resolved.
Posted Sep 01, 2023 - 08:45 EDT
Investigating
We are currently experiencing a service interruption. We are investigating and will provide updates as soon as possible. If you are not already logged in, you may not be able to access your Butterfly account until this issue is resolved.

We understand the significant impact this may cause. We will continue to track the status of this issue with the provider and will update you as soon as we know more. Please don't hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted Sep 01, 2023 - 08:45 EDT
This incident affected: Butterfly Cloud.