Butterfly iQ Android Mobile Application Outage - Version 2.23.0
Incident Report for Butterfly Network
Resolved
All Android users who have installed 2.23.0 should update to 2.23.1, which is available on the Google Play store as of Friday, March 3.
Posted Mar 05, 2023 - 15:19 EST
Identified
The issue has been identified and our team is currently working to resolve the issue and update the Google Play Store
Posted Mar 01, 2023 - 13:09 EST
Investigating
We are currently experiencing a system outage and you may experience an issue accessing Actions Menu on Android application version 2.23.0.
We understand the impact this may cause, and we will post an update as soon as it is resolved. Please don’t hesitate to contact Butterfly Support at https://support.butterflynetwork.com with any questions or concerns.
Posted Mar 01, 2023 - 09:59 EST
This incident affected: Butterfly Mobile App - Android.