Scheduled Maintenance March 25, 2026

Scheduled for Mar 25, 20:00 - 22:00 EDT

Scheduled

On Wednesday, March 25th at 8 PM EST, you may experience a brief outage while we perform system maintenance. You may not be able to access your Butterfly account during this time.
If you have issues after the scheduled maintenance, please contact Butterfly Support at support@butterflynetwork.com.

This release includes several enhancements and bug fixes including:

-Al Agent Controls
Compass Al clients now have self-service toggles to enable or disable Al features (Auto Exam Type, Documentation Agent, and QA Agent) directly from the Enterprise Settings.
A new "Al Management" permission has been introduced for enterprise admins, with corresponding updates to the permissions and profile settings pages.
Please note: these toggles will not disable Documentation Agent from the mobile application until the 2.48 mobile release in early April. To disable the mobile feature, please reach out to Support or your Client Success representative.

-De-identified Study Sharing (NBD Masking)
Enterprise Clients will now have the ability to de-identify Non-Butterfly Device studies for sharing and download.
This tool allows a user to draw a mask over the PHI (patient health information) on images and cines prior to download.
Masked images are included in exported study PDFs and shared studies.
Users can also hide the entire first page if a study includes a cover page containing patient demographics.

-Study Export Improvements
Users will now receive an in-app notification when a bulk study export job completes.
Study PDFs now respect worksheet visibility conditions — questions that are not visible based on conditional logic will no longer appear in exported PDFs

-Global Search Enhancements
Advanced Search now automatically adjusts its layout to ensure action buttons remain accessible regardless of screen size.
A "Must Include All" option is now available for Tags in Advanced Search, consistent with the existing behavior for Worksheets. This allows users to search for studies that contain all selected tags simultaneously, rather than any one of them.
A new "QA Reviewed By" column has been added to Global Search and Study View.
Organization Specialty Field
A new Organization Specialty field has been added across the platform. Admins can now set and update an organization's specialty during creation or editing, viewable in organization detail.

-Profile Settings
New profile setting options are now available for users to share more about their experience and interests. Fields include Ultrasound Experience, Applications of Interest, and Scanning Frequency. This information will be used to individualize user experiences in the future.

-Express Login (QR Code Login) ||
User preferences - including scan settings, presets, and notification preferences — will now be properly applied when logging in via Express Login (QR code scan).

-ScanLab
Fixed an issue where portfolio and review dashboard filters (author search, exam type search) were not returning correct results.
Fixed study counts not updating correctly in the ScanLab Portfolio Performance Indicator

-Dashboard.
Fixed dashboard pagination issues.
Smart QA scores now correctly respect visibility rules: scores are hidden from users who lack QA access, and are only shown to study authors once the study has been reviewed

-Shared Study Links
The video player on the shared study page is now centered for improved viewing.
Expired shared study links now redirect users to the Cloud application instead of showing an error.
Japanese Language Support Japanese translations have been added to the End User License Agreement (EULA).

Please note: feature availability may vary depending on a user's country and license type.
Posted Mar 12, 2026 - 02:13 EDT
This scheduled maintenance affects: Butterfly Cloud.