Scheduled Maintenance October 22, 2025

Scheduled for Oct 22, 20:00 - 22:00 EDT

Scheduled

On Wednesday, October 22nd at 8 PM EST, you may experience a brief outage while we perform system maintenance. You may not be able to access your Butterfly account during this time.

If you have issues after the scheduled maintenance, please contact Butterfly Support at support@butterflynetwork.com.

This release includes several performance improvements and bug fixes, including:
- Fixed a mismatch between the number of studies in a tasklist and the preview count displayed next to the tasklist title.
- Resolved multiple issues within the password reset workflow.
- Ensured that secondary authors are displayed immediately after being added to a study.
Posted Oct 20, 2025 - 15:36 EDT
This scheduled maintenance affects: Butterfly Cloud.