Partial Login Outage
Incident Report for Butterfly Network
Resolved
Service has been restored as of July 18, 1:20 PM ET.

Please don't hesitate to contact Butterfly Support at https://support.butterflynetwork.com with any questions or concerns.
Posted Jul 18, 2023 - 13:22 EDT
Update
We are currently experiencing a service interruption stemming from a system outage with a third party provider. If you are not already logged in, you may not be able to access your Butterfly account until this issue is resolved. The provider has confirmed they have identified the issue and is working on a fix.

We understand the significant impact this may cause. We will continue to track the status of this issue with the provider and will update you as soon as we know more. Please don’t hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted Jul 18, 2023 - 13:15 EDT
Investigating
We are currently experiencing a service interruption stemming from a system outage with a third party provider. If you are not already logged in, you may not be able to access your Butterfly account until this issue is resolved.

We understand the significant impact this may cause. We will continue to track the status of this issue with the provider and will update you as soon as we know more. Please don’t hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted Jul 18, 2023 - 13:06 EDT
This incident affected: Butterfly Cloud and Butterfly Store.