Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 04, 2026 - 20:00 EDT
Scheduled
On Monday, May 4th at 8 PM EST, you may experience a brief outage while we perform system maintenance. You may not be able to access your Butterfly account during this time. If you have issues after the scheduled maintenance, please contact Butterfly Support at support@butterflynetwork.com.
Please note: feature availability varies depending on a user's country, license type, permissions, and probe type.
-Worksheet Enhancements The worksheet editor has been updated to visually match the themes and coloring used throughout the Butterfly platform.
-Read-Only Role A new Read-Only Butterfly Access role is now available. Users assigned this role can view studies and data but are prevented from making edits across the platform and cannot access the mobile app. Many actions are hidden or disabled within the desktop cloud.
-Global Search Export Enhancements Enterprise Administrators can now include worksheet and QA data in Global Search exports by using the "Detailed Export" option.
-Study List Sorting The Study List view now supports additional sorting options such as Study Author, Exam Type, and more.
-Program Performance — "Last Year" Filter The Program Performance dashboard will now allow users to view data for the full prior calendar year.
-Downtime Notifications Improvements Several usability improvements to Downtime Notifications: the tab now auto-expands when enabled, deactivated users are automatically removed from notification lists, and the Selected User tab in Integration Alerts has been updated for clarity.
-What's New Page — Permission-Based The What's New page now displays tiles selectively based on the logged-in user's permissions, ensuring a more relevant experience.
-Auto Exam Type Mapping Compass Al clients can now enable automatic exam type mapping. This feature uses a Large Language Model (LLM) to map information received from a study (via DICOM tags) to an Exam Type to speed up documentation and improve study organization.
-Bug Fixes Analytics Export Failure - Fixed an issue where exporting from the Analytics > Stats dashboard was failing.
Share Bundle Thumbnails - Fixed a bug where video thumbnails were not visible when sharing studies via de-identified links.
Program Performance Dashboard in Safari - Fixed a rendering issue affecting how the dashboard displays in Safari.
Historical Proficiency Data Entry - Fixed a display bug affecting historical proficiency records.
Integration Alert Email Icon - Updated the icon used in integration alert notification emails. Aorta Exams - The "Aorta" Exam Type now displays in the Exam Type filter in ScanLab Cloud.
Posted Apr 22, 2026 - 14:43 EDT
This scheduled maintenance affected: Butterfly Cloud.