Butterfly Cloud Outage
Incident Report for Butterfly Network
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 22:59 EST
Investigating
We are currently investigating an outage with our Cloud application
Posted Feb 20, 2024 - 21:31 EST
This incident affected: Butterfly Cloud.