Pushes offline
Incident Report for Butterfly Network
Resolved
Service has been restored.

Please don't hesitate to contact Butterfly Support at https://support.butterflynetwork.com with any questions or concerns.
Posted Oct 11, 2023 - 16:04 EDT
Investigating
Butterfly has received reports of Butterfly Cloud latency that may impact performance sending DICOM or HL7 messages to downstream systems. We understand the impact this may cause, and we will post an update as soon as more information is available.

Please don't hesitate to contact Butterfly Support at https://support.butterflynetwork.com with any questions or concerns.
Posted Oct 11, 2023 - 14:57 EDT
This incident affected: Butterfly Cloud and Butterfly Store.