DICOM Image Display Disruption

Incident Report for Butterfly Network

Resolved

Our engineering team has implemented a fix and the issue is resolved. DICOM images from non-Butterfly devices within the Butterfly platform are now displaying as expected.

We understand the significant impact this may have caused. We will continue to monitor. Please don't hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted Jul 15, 2025 - 18:04 EDT

Identified

We are currently experiencing a partial service disruption affecting the display of DICOM images from non-Butterfly devices within the Butterfly platform. Users may encounter issues loading or viewing these images.

Our engineering teams have identified the root cause and are actively working to restore full functionality as quickly as possible. At this time, all other services remain fully operational.

We understand the significant impact this may cause. We will continue to track the status of this issue with the provider and will update you as soon as we know more. Please don't hesitate to email support@butterflynetwork.com or call us at 1-855-296-6188 with questions or concerns.
Posted Jul 15, 2025 - 16:30 EDT
This incident affected: Butterfly Cloud.