We are continuing to work on a fix for this issue.
Posted Nov 04, 2025 - 09:44 EST
Identified
We have identified the issue and have implemented a remedy. Please let us know if you are seeing any issues.
Issue Summary: Some customers are unable to search for users within the Enterprise Users list. Searching within individual Organization lists continues to function normally. This issue does not impact core platform functionality such as scanning, storing, or reviewing studies, but may affect user management activities.
We understand the inconvenience this may cause and appreciate your patience. We will share updates as we learn more. If you have questions or need assistance, please contact us at support@butterflynetwork.com or call 1-855-296-6188.
Posted Oct 27, 2025 - 16:48 EDT
Update
We are continuing to investigate reports that some customers are unable to search for users within the Enterprise Users list. Searching within individual Organization lists continues to function normally.
This issue does not impact core platform functionality such as scanning, storing, or reviewing studies, but may affect user management activities.
We understand the inconvenience this may cause and appreciate your patience. We will share updates as we learn more. If you have questions or need assistance, please contact us at support@butterflynetwork.com or call 1-855-296-6188.
Posted Oct 27, 2025 - 12:46 EDT
Investigating
We are investigating reports that some customers are unable to search for users within the Enterprise Users list. Searching within individual Organization lists continues to function normally.
This issue does not impact core platform functionality such as scanning, storing, or reviewing studies, but may affect user management activities.
Our team is actively investigating and working to restore normal functionality.
We understand the inconvenience this may cause and appreciate your patience. We will share updates as we learn more. If you have questions or need assistance, please contact us at support@butterflynetwork.com or call 1-855-296-6188.