Service Degradation
Incident Report for Butterfly Network
Resolved
Service has been restored as of ~9:30PM ET on October 17th, 2022.

Please don't hesitate to contact Butterfly Support at https://support.butterflynetwork.com with any questions or concerns.
Posted Oct 18, 2022 - 16:21 EDT
Monitoring
We're seeing recovery but will continue to monitor. If all remains optimal, we will update here and mark this incident resolved.
Posted Oct 18, 2022 - 07:34 EDT
Identified
We are currently experiencing service degradation and you may experience an issue accessing your Butterfly account. We are working diligently to rectify the issue as soon as practicable and will post an updated as soon as it is resolved.
Posted Oct 17, 2022 - 19:02 EDT
This incident affected: Butterfly Cloud.